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The ENVI® Pocket Guide is a quick reference booklet not intended to be 
read from cover to cover although it can be. The intent is to provide users 
with succinct steps on how to accomplish common tasks in ENVI.  
 
If you need or desire comprehensive explanations of tasks from this guide 
refer to the following resources: 

ENVI Documentation Center 
l3harrisgeospatial.com/docs  

ENVI Tutorials 
l3harrisgeospatial.com/docs/tutorials.html  

ENVI Videos 
l3harrisgeospatial/Learn/Videos    

ENVI Help Articles 
l3harrisgeospatial.com/Support 

Tech Support 
(+1)303-413-3920 

Email Support 
geospatialinfo@L3Harris.com
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OPENING ENVI

1. �Please reference ENVI Pocket Guide Volume 1 | BASIC if you need 
instructions on how to open ENVI, load and remove data, descriptions 
of the interface components, and basic data preparation procedures. 

ENVI Pocket Guide Volume 1 | BASIC  
provides an introduction to familiarize users with common methods 
for opening ENVI, loading data, navigating, and performing stretches. 
 
You are currently referencing  
ENVI Pocket Guide Volume 2 | INTERMEDIATE  
which expounds a step further on intermediate procedures using ENVI, 
IDL and ENVI LiDAR, assuming you have already mastered the basics. 

GETTING STARTED
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GRID REFERENCE

1. �Load an image (nadir, 
off-nadir, referenced  
or unreferenced) into 
ENVI, then right-click  
the image in the Layer 
Manager and select 
Zoom to Layer Extent. 

If your image is georeferenced, you will not be able to record 
coordinates. However, you will still be able to count features and 
record the File (x,y) values. Toggle the check boxes next to Symbol, 
Label, Description, Count or Coordinates to determine which  
attributes will be labeled.
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2. �Click the Feature Counting Tool button  to open the Feature 
Counting dialog. Right-click on Description to turn on coordinates or 
File (x,y) values for unreferenced images. 

3. �Enable the Grid 
check box. By 
default, the Grid is 
set to 4 x 4. You can 
adjust the grid size 
by entering different 
values in the fields 
provided. 
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CE 4.� �Click the Feature Counting Properties button  to edit the feature 
properties such as the Feature Name, Font Size, Symbol, Label Position, 
Show Label, and Show Count. 

5. �Close the Feature 
Counting Properties 
dialog. Add more 
features by clicking the 
Add Feature button 

. Change the default 
Feature Name (Feature1) 
in the name field.
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6. �Select the Feature Name of the feature you want to count using the 
drop-down arrow in the Feature Name field. Begin counting by clicking 
on the features in your image. 

7. �As you count the features, click Description and enter in the attribute 
and associated information. 

8.� �You can delete mistakes by highlighting the feature row(s) and clicking 
the Delete Point button  to delete individually or the Delete All 
Points button  to delete all.

9. �To add a geographic grid, click the Annotations button  then 
select Add Grid Lines. The new grid often defaults to WGS 1984 Web 
Mercator Projection.
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10. �You can edit the grid in the 
Grid Edit Properties that is 
located directly underneath 
the ENVI Toolbox. Here, you 
can change the Coordinate 
System, Text and Line Color, 
XY Spacing and other grid 
properties as shown in the 
following example: 
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11. �Go to the ENVI main menu and click File > Chip View To > PowerPoint 
or PDF for a finished product. Also known as the Report Generation 
Tool, chipping to PowerPoint allows you to utilize a variety of ENVI’s 
built-in product briefing templates. 
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CE Example NADIR with Reference and Off NADIR without Reference:



13

1. �Load a multispectral or hyperspectral 
image into ENVI, then select Band  
Algebra > Band Math from the Toolbox. 
The Band Math dialog appears.  

2. �Enter a simple or complex mathematical 
expression using b# variables to represent 
the bands you want to manipulate. 
Replace # with the band number as 
shown in the example.

Band Math is a method used to create new raster data by performing 
complex or simple mathematical functions on existing bands available in 
one or more geographically referenced images. Analysts will be able to 
compress data into isolated values of interest such as NDVI (Normalized 
Difference Vegetation Index). 

BAND MATH
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3. �Next, click Add to List then OK 
to open the Variables to Bands 
Pairings dialog.

4. �Initially, the variables are undefined. 
One by one, highlight each variable 
used in expression and click 
the corresponding band in the 
Available Bands List to define the 
variables. 

5. �To save the image, click File,  
then click Choose and navigate 
to an Output Directory. Name the 
output file and click Open. For  
a memory-only output, click  
Memory. Click OK.
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6. �Check your results 
by linking two 
Views; one View 
with a corresponding 
spectral composite 
that matches the 
bands manipulated 
in your expression, 
and the other  
containing the output 
image. Use the 
Cursor Value button 

 to evaluate and 
confirm the results.
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H Example Band Math on Landsat 7 Input b4 + b3 + b2 = Output:
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1. �Open the images you want to layer 
stack, then click Raster Management > 
Build Layer Stack in the Toolbox. 

2. �In the Input Rasters field, click the  
Browse button  to open the Data  
Selection dialog. Click Select All or use 
the Ctrl or Shift key to select the files that 
will comprise the layer stack. Click OK.

The Build Layer Stack tool is used to construct a new multi-band  
image from georeferenced images of various pixel sizes, extents, and 
projections. Input bands are resampled and reprojected to a common 
spatial grid. The resulting image will comprise the extent of all the  
images or only the region of overlap. 

BUILD LAYER STACKS
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3. �Using the SHIFT or CTRL key, highlight each image you wish to stack, 
and then click OK. 

4.� Next click Reorder Files and then drag and drop the bands in the proper 
order from least to greatest then click OK.

5. �Accept the Grid Definition default or choose a different option from 
the drop-down list to which the input images will be resampled and 
reprojected. A Grid Definition contains a known coordinate system plus 
any combination of other parameters such as pixel sizes, image dimen-
sions, and tie point coordinates for the upper-left pixel.

6. �Depending on what you select to define the Grid Definition, additional 
fields will display in the Build Layer Stack dialog such as Extents (De-
grees), Pixel Size (Degrees), Image Size, and Tie Point field. 
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7. �Use one of the following methods to define the output coordinate 
system of the layer stack in the Coordinate System field: 

         a. �Click the Browse button  to manually define the coordinate 
system in the Select Coordinate System dialog.

         b. �Click the From Dataset button  to use the grid definition of an 
existing dataset.

         c. �Click the From Current View button  to use the grid definition 
from an existing view.

         d. �Click the Calculate Union/Intersection button  and select the 
Intersection option to include the extent encompassed by all of 
the rasters. Or, select the Union option to include only the extent 
where they overlap.

         e. �Click the Draw Bounding Box button  to define a box outlining 
the extent of the layer stack. In the view, click and drag the  
cursor to draw a box of the extent.
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G 8. �Select a Resampling Method from 

the drop-down list. Click the Help 
button  for more information 
on resampling.

9. �For the Output Raster, choose File 
if you want to save the output file. 
Next, click the Browse button  
to navigate to an Output Directory. 
Name the output, and then click 
Save. If you want a memory-only 
output, choose Virtual Raster.

10. �Enable the Display result check 
box if you want to open the  
output file after processing.

11. Click OK.
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Example of a new multi-band image built from stacked images using 
Calculate Union:
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Shortwave Infrared (SWIR) bands can be exploited to detect materials 
that are otherwise invisible when using visible and/or other multispectral 
imagery (MSI) bands. The following sensors collect SWIR Information: 
WorldView-3, Landsat (4, 5, 7 and 8), SPOT (4 and 5), Terra & Aqua 
(MODIS / ASTER), GISAT-1, Sentinel (2, 5, and 5P), and VIIRS.

SWIR BANDS
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1. �Load an atmospherically corrected SWIR image into ENVI. If your image 
is not atmospherically corrected , use the Quick Atmospheric Correction 
(QUAC) Tool in the ENVI Toolbox to perform the atmospheric correction. 

2. �Take some time to get familiar with the image using the Navigation 
Tools. Next, explore each SWIR band. 

3. �Right-click the SWIR image in the Layer Manager and select Band An-
imation. Toggle and drag the corners of the Band Animation dialog to 
expand it if necessary.

SW
IR
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S 4. �The Play buttons  allow you to Play backward, Pause, or Play forward 

through each of the SWIR bands to visualize which ones show high  
reflectance for the feature(s) of which you are interested.

5. �Click the Tool button , then > Annotate 
> Frame number to dynamically display the 
SWIR bands using Band Animation. Click and 
hold the top of the Band Animation dialog 
and drag away from the center of the View 
so it does not obscure the image. 
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6. �Once you click Play forward or Play backward, you can adjust 
the playback speed using the Delay dropdown menu. 

7. �Right-click the SWIR_<your image name>.series in the 
Layer Manager and select Change Color Table > Rainbow. 
This technique makes it easier to identify high reflectance 
pixels per SWIR band. Once you have identified the high 
reflectance bands for the material of which you are inter-
ested, close the Band Animation dialog.

8.� �Click the Data Manager  and load a SWIR False Color Composite using 
the bands you have previously identified. The example in this guide  
displays SWIR 7 as Red, SWIR 1 as Green, and SWIR 5 as Blue. Click Load 
Data to open the composite in the same View or enable the Load in New 
View check box prior to clicking Load Data to open in a separate View. 
Press Ctrl+L or go to Views in the main menu to link the Views.  

SW
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9. �If you have a multispectral image 
over the same region, load it as 
a True Color Composite into the 
same View or Linked Views. 

10. �Highlight the MSI True Color 
Composite in the Layer  
Manager and press Alt+Z to 
open a Spectral Profile dialog. 
This dialog can also be opened 
by clicking the Spectral Profile 
button  in the main menu or 
right-clicking on the composite in 
the Layer Manager and selecting 
Profiles > Spectral. Repeat these 
steps and open the Spectral 
Profile for the SWIR False Color 
Composite (SWIR 715). 

SW
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11. �Position the two 
Spectral Profile dialogs 
side-by-side for easy 
comparison. Use  
the Shift+left-click 
keystroke to select 
and compare the 
spectra. 

12. �In the above example, the image to the left is an MSI True Color  
Composite and the image to the right is a SWIR 715 False Color 
Composite. Notice that in the true color image, the roof in the 
cross hair appears to be of the same materials as the left adjacent 
roof. However, in the SWIR false color image, the two roofs are of  
different materials. 

SW
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S 13. �If you wish to classify your SWIR image at this point, type “Spectral” 

in the Toolbox search window and double-click the Spectral Angle 
Mapper Classification Tool. For a comprehensive tutorial and explanation 
of this tool, visit the ENVI online Documentation Center at:

	  
      www.l3harrisgeospatial.com/docs/spectralanglemapper.html

Visit http://speclab.cr.usgs.gov for a comprehensive list of materials in 
association with best SWIR bands used to identify specific materials. 
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1. ��Spectral Profile with X & Y axis

2. �Remove selected curve, Remove 
all curves, Edit data value

3. �Show/Hide Properties

4. �List of collected spectra/ classes

5. �Show/Hide extra info, General 
Properties, Curve/ Spectra  
properties

6. �Stack plots, Reset plot range

7. �Choose Y axis 

8. �Choose X axis 

9. �(X) Electromagnetic Spectrum/ 
Wavelengths in nanometers

10. �(Y) Data Value 

11. �Import ASCII or Spectral library, 
Export ASCII, Spectral Library, 
PDF, Image or PPT, Profile  
Window Options

12. �1 x sample spectra plot (select 
multiple by clicking image 
while holding Shift)

SPECTRAL ANALYSIS

Spectral Profile Interface  
Some numbers represent GUI groups separated by commas from left to right.
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IS 1. �Load a SWIR 715 False Color 
Composite image into ENVI. 
Highlight it in the Layer  
Manager, then go to the 
main menu and click Display 
> 2D Scatter Plot. The Scatter 
Plot Tool appears. 

Shortwave Infrared (SWIR) bands will be used again in this section to 
further investigate the differences in materials using the 2D Scatter 
Plot together with the Spectral Profile. These methods can be applied 
on any image containing more than one band.
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2.� In the Class value field, highlight the default Class 1 and define it 
according the material you want to compare. Type a feature name and 
assign it an appropriate color. Click the Add Class button  to add and 
define more spectral classes for comparison. The class examples used in 
this guide are Roof Type 1 and Roof Type 2. 

3. �Click the Toggle Density Slice button  to apply a color slice to your 
plot. You can change the color scheme by clicking Options > Change 
Density Slice Lookup. 

4. �Leave Full Band unchecked. The Full Band option allows you to utilize 
the pixel statistics from the entire image. Left unchecked, the Scatter 
Plot Tool will only show the statistics contained within the current  
extent within the View. 

5. �Change the Scatter Plot bands by clicking File > Select New Band > 
X-Axis or Y-Axis. The plot example in this guide shows SWIR 1 on the 
X-Axis and SWIR 5 on the Y-Axis.
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6. �Right-click anywhere 
in the Scatter Plot and 
select a Patch Size. 
Select your first class 
in the Class value field. 
Next, use any of the 
following keystrokes and 
hover over an area in 
the Scatter Plot with a 
dense collection of pixels: 
Ctrl+left-click, Shift+left-
click, or Alt+left-click. 
Notice that as you move 
the mouse over the pixels 
in the Scatter Plot, the 
corresponding pixels in the image in the View are dynamically highlighted. 
Back in the Class value field, select the next class and repeat these steps 
to evaluate the plot pixels and Spectral Analysis their correlating data values 
in the View. Conversely, click and hold the left mouse button in the View 
to dynamically highlight the corresponding Scatter Plot.
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7. �Left-click and hold inside the Scatter Plot and draw a polygon around 
the same general area with a dense collection of pixels to select them. 
If you need to delete and redraw your polygon, right-click on it, then 
select Clear All. Once you are satisfied with the polygon for your first 
class, go to the Class value field and select the next class. Then draw its 
corresponding polygon. Repeat these steps to create spectral samples 
for all of your classes. 

8. �Right-click in the Scatter Plot and 
select Export all Classes to ROIs. 
The ROI Spectral Analysis Classes 
will automatically be added  
under the False Color Composite 
in the Layer Manager. 
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9. �Back in the Scatter Plot, 
right-click and select 
Mean All. This gives you 
the statistical mean for 
all the spectra captured 
within the ROI classes. 
Press and hold the Shift 
key and right-click on 
several disparate pixels 
in the plot to show the 
graphical comparison 
of the mean deviation 
among the spectra. This 
indicates the degree of 
correlation between the 
X and Y band choice. 
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10. �In the Layer Manager, right-click 
the ROI Classes and select Statistics 
for All Classes. Select the SWIR 
715 False Color Composite band 
combination in the Data Selection 
dialog and click OK. 

SPECTR
AL AN

ALYSIS

Standard Deviation is the average distance from the mean for the 
spectral material in question. You may save your findings to a Spectral 
Library for future comparisons. Go to File > Export to Text File to save 
your findings as a report. 
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1. �Open the metadata file  
(*_MTL.txt) in ENVI.

2. �Type “QUAC” in the Toolbox search 
window and double-click QUick 
Atmospheric Correction (QUAC).

Spectral reflectance curves are used to distinguish materials that 
make up the earth’s surface. Spectral libraries are primarily created 
in the field using a spectrometer instrument. Satellite images require 
calibration before comparing against spectral libraries because  
satellites measure radiances, which are often tainted by atmospheric 
variables such as aerosols, shadows, clouds, and the sun’s position, 
thus resulting in distortion. 

IMAGE CALIBRATE
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2. �Type “QUAC” in the 
Toolbox search window 
and double-click QUick 
Atmospheric Correc-
tion (QUAC).

3. �Select the multispectral 
image in the Select 
Input Data dialog, then 
click Spatial Subset. 
Draw a box around the 
region you will analyze, 
avoiding heavily clouded 
areas and large bodies 
of water. Click OK.
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E 4. �In the QUAC dialog, the Input Raster field and Sensor Type are already 

populated. The Sensor Type is derived from the metadata. If ENVI cannot 
recognize the sensor, you can select Generic/Unknown Sensor.  
For the Output Raster, select 
Virtual Raster for a memory-only 
output. To save, browse to an 
Output Directory and name the 
output file. Click Save. Enable 
the Preview check box and a 
preview of your subsetted image 
will open in a new View. If you 
are satisfied with the preview, 
enable the Display result check 
box and click OK.

5. Link your Views and inspect the results by analyzing the Spectral Profiles. 
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LANDSAT before and after atmospheric correction: 
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1. ��New Project, Open Project or LAS, Process Data, QA Mode, QA Mode 
with Center Line, 3D Viewer, Select Cross Section, Cross Section Top 
View, Reset Perspective View, Reset Isometric View, Measurement Tool, 
Height Palette Editor, Color by Height, Color by Classification, Shade 
by Intensity, Color by RGB, Color by Viewshed Analysis, Filter Points by 
Height, Launch Products in ENVI, Launch Products in ArcMap,  
Screenshot to PowerPoint

2. �Main Viewer Window

3. Session Operations Log

4. �Navigation Tools, Navigation Window

5. �Layer Manager

LIDAR FEATURE EXTRACTION

ENVI LiDAR Interface  
Some numbers represent GUI groups separated by commas from left to right. 

For a more comprehensive understanding of ENVI LiDAR, visit the online 
Documentation Center, Videos and Tutorials. 
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1. �Open ENVI LiDAR by clicking Start > All Programs > ENVI 5.x >  
ENVI LiDAR 5.x (32-bit).
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2. �Click File > New Project and navigate to the directory where you wish 
to save your ENVI LiDAR project. Name your project with *.ini extension, 
such as yourProjectName.ini. The .ini is the file extension used to save 
LiDAR Project sessions. You may open existing projects by locating .ini 
files via File > Open. 

3. �Click OK when prompted to select the LAS or other data to be imported 
for your project. Navigate to the directory containing your LAS file and 
open it. 
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4. �The next prompt asks if you want to import more raw material data 
files into the project. Click Yes if you want to add more data, other-
wise click No. The final prompt asks if you want to use the Projection 
information read from file. Click Yes.
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appear if you need to change 
the coordinate system of your 
input file. Define your coordi-
nate system and click OK.

6. �You may change the point 
cloud symbology using one of 
the following: Height Palette 
Editor , Color by Height 
, Color by Classification , 
Shade by Intensity , or Color 
by RGB  if the LAS file  
contains the necessary metadata.
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7. �Click the Height Palette  
Editor. At the bottom of the 
dialog, click the Load palette 
drop-down menu and select 
Earthtones. Click OK. 

8. �In the Navigation Window, 
left-click and drag a rectangle 
around the region where 
you will extract features. 
You may use the entire 
frame, but the larger the 
area, the longer it will take 
to process.
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9. �Click the Process Data button .  
The Project Properties dialog appears. 

10. �If you check Produce Point Cloud, 
ENVI LiDAR will generate a new 
classified Point Cloud which adheres 
to the classification standard and 
format specification set forth  
by the American Society for  
Photogrammetry and Remote  
Sensing (ASPRS) LAS Specification 1.x.
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11. �This exercise will extract buildings and trees. Check Produce 
Buildings and Produce Trees.
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12. �Accept SHP format (*.shp) as the file formats for both features. Adjust 
the File Size Limit if necessary or accept the default value of 500MB. The 
output data will be saved to the Products Folder that was automatically 
generated within the directory containing your ENVI LiDAR project.

13. Click Start Processing.

14. �ENVI LiDAR will default to QA Mode once processing is complete. 
Click OK.

LI
D

AR
 F

EA
TU

R
E 

EX
TR

AC
TI

O
N



51

LID
AR

 FEATU
R

E EXTR
ACTIO

N

15. �While in QA Mode, double-click any 
of the vector layers within the Main 
Viewer Window and select from the 
following options to make any  
necessary corrections:

16. �Once satisfied with edits, you may 
Launch Products in ENVI , Launch 
Products in ArcMap , or Screenshot 
to PowerPoint  for a finished product.

17. �Click the 3D Viewer button  to display a 3D Model of your data. In 
the ENVI LiDAR 3D Viewer, select File > Screenshot to PowerPoint to 
create a finished product.
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Sample 3D view from point cloud:
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BATCH PROCESSING

Interactive Data Language (IDL) is the programming language that 
drives ENVI. Users can use IDL alone or in tandem with ENVI by use 
of the ENVI API. The ENVI API uses an object oriented methodology to 
manage and manipulate data, views and the overall state of the  
application. Many workflows require routine steps that users must 
perform whenever they want a particular product or result. Such 
workflows can be automated using ENVITasks, thus improving 
efficiency while mitigating user error. This approach is commonly 
referred to as batch processing, which generally means to collect  
a set of instructions or jobs and then execute the set without  
user intervention. The IDL code example shown in this section 
demonstrates how to batch subset and reproject every image in  
a specified directory. 
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IDL Workbench Interface  
Some numbers represent GUI groups separated by commas from left to right. 

1. ���Main Menu/Toolbar: New Program, New Project, Open, Save, Cut, 
Copy, Paste, Undo, Redo, Back, Forward, Compile, Run, Stop, Step In, 
Step Over, Step Out, Call Stack, Reset

2. �Program Editor Window

3. �IDL Console/ Sandbox

4. �Tabs: Project, Outline,  
Variables | List of Project Variables

Refer to the online IDL documentation for a more comprehensive 
explanation of the IDL Workbench. 
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G 1. Open IDL by clicking Start > All Programs > IDL 8.x > IDL 8.x. 

2. �Click the New Pro File button  to create a new empty program script.

3. �Select File > Save As and navigate to an Output Directory. Name 
the program batchReprojectDirectory.pro. Click Save. 

A general understanding of object oriented programming and coding 
conventions are useful when working with IDL. The following resources 
will be of use in building your understanding:

Object Oriented Programming:  
www.geo.mtu.edu/geoschem/docs/IDL_Manuals/OBJECT%20PROGRAMMING.pdf
 
Coding Conventions: 
www.harrisgeospatial.com/docs/case_versus_switch.html
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4. �Right-click in the Program Editor 
Window, select Preferences, then 
check Show line numbers. This will 
help identify errors if debugging is 
necessary. Click OK.

5. �In the Program Editor Window,  
enter the following lines of code:

6. �The code in blue must match the 
filename. All IDL programs start 
and end in this way.
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G 7. �Use a semicolon (;) to comment your code. This ensures good logic and 

code readability for other users. 

8. �Begin writing actual 
code to accomplish 
each commented step.

Note: The input \01Batch and output  \ Reprojected directories must 
be created ahead of time. 
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9. �The first four commands start the ENVI application, set the input directory, 
set the output directory, and create an array of input files. IDL will search 
the input directory for all TIFF files.
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variable. Use comments to add placeholders for code that will subset and 
reproject the files with each iteration.

11. �Use ENVITasks to manipulate data in ENVI, such as subsetting and 
reprojection. Take advantage of code examples provided in the ENVITask 
documentation. Go to www.l3harrisgeospatial.com/docs/envitask.
html. Scroll below TaskName until you find a task applicable to the 
problem you need to solve. For this exercise, click ReprojectRaster and 
notice there is a code snippet that already accomplishes 90% of what 
you need to do. Highlight and copy the ENVITask snippet from Raster = 
e.OpenRaster(File) to the last line.



61

BATCH
 PR

O
CESSIN

G

12. �Go back to the IDL 
Program Editor Window 
and highlight the last 
three comments. Then 
paste the ENVITask 
snippet. Highlight any 
of the newly pasted 
codes not indented 
properly and hit the 
Tab key until they are 
properly indented under 
the for loop. Then type 
endfor as shown.
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Sub_Rect and COORD_SYS_CODE to coincide with your data. The 
subset rectangle’s upper left and lower right can be obtained using 
the Cursor Value in ENVI. To obtain your desired COORD_SYS_CODE, 
navigate to  
C:\Program Files\Harris\ENVIxx\IDLxx\resource\pedata\predefined.  
The coordinate systems are “…Strings.txt” files. DO NOT modify 
these files.

14. �Add the following lines of code to write the new output rasters, then 
click the Compile button . Check the IDL Console/ Sandbox for 
any errors. Red in the Console indicates errors and green indicates a 
successful compile:

15. �If your program has errors, use the line number in the error message 
to address the issue. Otherwise click the Run button  to execute 
the program.
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Complete Batch Subset & Reproject Directory Example:
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