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The ENVI® Pocket Guide is a quick reference booklet not intended to be 
read from cover to cover although it can be. The intent is to provide users 
with succinct steps on how to accomplish common tasks in ENVI.  
 
If you need or desire comprehensive explanations of tasks from this guide 
refer to the following resources: 

ENVI Documentation Center 
l3harrisgeospatial.com/docs  

ENVI Tutorials 
l3harrisgeospatial.com/docs/tutorials.html  

ENVI Videos 
l3harrisgeospatial/Learn/Videos    

ENVI Help Articles 
l3harrisgeospatial.com/Support 

Tech Support 
(+1)303-413-3920 

Email Support 
geospatialinfo@L3Harris.com
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1. �Open file, Data Manager, Chip to 
PowerPoint (Report Generation)

2. �Scroll View, Cursor Value, Select, 
Pan, Fly, Rotate

3. �Zoom, Fixed Zoom In/Out, Full 
Extent, Percent/Ratio

4. North Up, Type or Preset Angle

5. �Arbitrary/Spectral Profile, Scatter 
Plot, ROI, Feature Count

6. �Digitizing, Vectors, Enhanced 
Annotations

7. Go To Coordinate

8. �Brightness

9. �Contrast

10. �Histogram Stretch 

11. Sharpen

12. �Transparency, Mensuration 
Portal, Blend, Flicker, Swipe

13. Layer Manager

14. Data Viewer/Image Window

15. Toolbox

16. �Cursor Value, Status Bar

ENVI® INTERFACE KEY

Some numbers represent GUI groups separated by commas from left to right.
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GETTING STARTED

OPENING ENVI

1. �On Windows, click Start > All Programs > ENVI 5.x > ENVI for ArcGIS® 
> ENVI 5.x (32-Bit). This method allows you to interface with ArcMap. 

2. �To open ENVI in 64-bit mode, click Start > All Programs > ENVI 5.x > 
64-Bit > ENVI 5.x (64-Bit). This method does not allow you to interface 
with ArcMap.

3. �To open ENVI programmatically via IDL, click Start > All Programs > IDL 
8.x > IDL 8.x. The IDL window appears. In the IDL Console, type the 
following code: IDL> E = ENVI(). Then press the Enter key and 
ENVI will soon launch. 

This is an introduction to familiarize users with common methods for 
opening ENVI, loading data, navigating, and performing stretches.
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LOADING & REMOVING DATA

4. �To load data, click the Open File 
icon . An explorer window will 
open. Navigate to the disk location  
of the file you wish to open.

5. �Select the file and click Open. 
ENVI’s native file format is .dat, but 
ENVI recognizes and reads most 
common formats such as: .img, 
.ntf, rpf, .tiff, .las, .dt, dppdb, .sid, 
.shp, .evf, .jp2, and many more.

6. �Another method is to click the 
Data Manager icon . The Data 
Manager appears, as seen on the 
previous page:

Windows Data Drag & Drop 
Functionality is fully supported 
in ENVI. 

GETTIN
G STAR

TED
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7. �Load additional layers by clicking  in the Data Manager. Explore  
different band combinations within the current view or a new view  
by clicking Load Data.

8. �If wavelength information is available for the 
bands of an image, right-click on an image 
layer in the Layer Manager to load true-color 
or color-infrared (CIR) band combinations;  
for example:  

9. �The Data Manager provides other  
data-management options:                                                                                                                                      
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NAVIGATING WITHIN A VIEW

10. �Use ENVI’s intuitive navigation tools to perform the following  
within a view: 

11. �Use ENVI’s intuitive image display tools to perform the following 
within a view: 

GETTIN
G STAR

TED
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SEAMLESS MOSAIC

1. �From the Toolbox, select Mosaicking 
> Seamless Mosaic. The Seamless 
Mosaic panel appears. You will set 
all mosaic options within this single 
panel. Click the Help button in the 
lower-left corner of the panel if you 
have further questions.

2. Click the Add Scenes button . 

Before beginning, some imagery requires preparation such as cropping 
to remove distorted edges to ensure optimal output results. 

MOSAIC
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3. �Click the Open File button  in the Data Selection dialog.  
A file selection dialog appears.

  
4. �Navigate to the folder 

containing the image data, 
and use the Ctrl or Shift key 
to select the files you need 
to mosaic. Click Open. The 
Data Selection dialog lists all 
selected scenes.

5. Click the Select All button.

6. Click OK.

7. �The Seamless Mosaic dialog 
should look similar to the 
example on this page.  
Highlight all images using 
the main column.

M
O

SAIC



14

8. �Right-click the Data Ignore Value column header and select Change 
Selected Parameters to set your value. In most cases None will be used.

 
9. �Highlight all images, then right-click and select Feathering Distance. 

Select Change Selected Parameters to set the value between 10 and 20 
pixels or more, depending on image quality and resolution. 

10. �Click the Color Correction tab and toggle Histogram Matching.  
Accept the default of Overlap Area Only if you want to compute 
statistics from areas where the reference image overlaps with adjusted 
images. When there is at least 10% overlap between scenes, histogram 
matching based on statistics from overlapping areas performs better 
than statistics from the entire scene. Select Entire Scene if you want 
to compute the entire image. Go back to the Main tab and set your 
desired reference image under the Color Matching Action column.  
All others will be matched. 

11. �Click the Seamless drop-down arrow and select  
Auto Generate Seamlines.

M
O

SA
IC
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 12. �Toggle the Show Preview check box. The system may take a  
few minutes to generate a preview, depending on your system  
specifications.  

13. Use the Zoom tools to visually inspect the image before exporting it. 

14. �If you are not satisfied with the previewed result, go back to the 
Main tab and adjust the reference image under the Color Matching 
Action column. Adjust the Feathering Distance values if needed.  
If the “None” Data Ignore Value doesn’t completely eliminate edge 
noise, you may need to crop the input image(s) in question before 
mosaicking.

15. �If you are satisfied with the preview, proceed to the Export Tab.  
Optionally, use the Define Output Area tool before exporting to 
crop and designate a perfectly square or rectangle output.

16. Select ENVI or TIFF output format.

17. Browse to an Output Directory and name the output file.

M
O

SAIC
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18. �Enable the Display result check box if you wish to display the result 
after exporting.

 
19. �Enter the Date Ignore Value that you defined in the Main tab. If you 

want more control over the pixels of the output, you may enter a 
different value. However, the value must be within the range of the 
input scenes. Click the Help button  for more details.

20. �Choose the desired Resample Method. 

21. �Click the Select Output Bands  button if you wish to specify the 
bands to export. By default, all bands are selected.

22. Click Finish.

M
O

SA
IC
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QUICK MOSAIC

METHOD 1:  
LAYER MANAGER

1. �If your rasters are loaded in ENVI, 
right-click on the View layer in 
the Layer Manager, and select 
Quick Mosaic. The Quick Mosaic 
dialog opens.

As its name suggests, Quick Mosaic quickly creates a virtual raster from 
multiple overlapping or adjacent georeferenced rasters. It allows users to 
evaluate multiple rasters using a single raster without going through the 
steps and processes of a Seamless Mosaic.
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2. �By default, all of the rasters in the Layer Manger are selected in the Input 
Rasters field. Use the Ctrl or Shift key to deselect any individual rasters that 
you do not want to include in the mosaicking process.

3. �Enter the values of the border pixels in the Data Ignore Value field. 
Those pixels will be ignored and become transparent in the virtual  
mosaic. You may also leave the Data Ignore Value field blank.

4. Enter a name in the Mosaic Name field or accept the default.

5. �Accept the Yes default for the Remove Layers option if you want to 
remove the input rasters from the Layer Manager after the virtual raster 
is created. Select No if you want to keep the input rasters.

6. Click OK.

Q
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METHOD 2:  
ENVI TOOLBOX

1. �Select Mosaicking >  
Quick Mosaic.

2. �Click the Browse button  in 
the Input Rasters field. The  
Data Selection dialog opens.

3. �If the rasters to be mosaicked 
are loaded in ENVI, they will 
appear in the Select Input Data 
field in the Data Selection  
dialog. Click the Select All  
button or use the Ctrl or Shift 
key to select your input rasters.
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not listed in the Select Input Data 
field, click the Open File button 

 to navigate to the rasters’ 
directory.

5. �Use the Ctrl or Shift key to se-
lect the rasters to be mosaicked. 
Click Open, then click OK to 
close the Data Selection dialog.

6. �The Quick Mosaic dialog should 
look similar to the example on the 
next page.

7. �Enter the value of the background 
or border pixels in the Data Ignore 
Value field, or leave it blank.

8. �For the Output Raster option, 
accept the Virtual Raster default if 
you want a memory-only output. 
The virtual raster will be created 
and displayed, but it will not be 
saved. Choose File if you want to 
save the output.

9. �When you choose File, you will be 
prompted to navigate to an output 
directory. Name your output raster, 
then click Save.

10. �Back in the Quick Mosaic dialog, 
ensure the Display result check 
box is enabled.

11. Click OK.
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1. �Click the ROI Tool icon  and draw a 
square or polygon over the extent of the 
image you want to subset. Double-click 
to finish drawing the shape. Name the 
ROI you just created or leave it set to the 
default name of ROI #1. 

2. �From the Toolbox, select Regions of  
Interest > Subset Data from ROIs.

3. �Under Select Input File, highlight the  
image that will be subset.

Subsets will be performed using Regions of 
Interest (ROI). Supported ROI inputs include 
.xml files created with the ROI Tool, .shp 
files, and ENVI Classic .roi and .evf files.

SUBSET
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4. �Under Select Input File, highlight the image that will be subset. 

5. �The Select Input File to Subset via ROI dialog also gives you the option 
to Select By: File or Band using this button: 

    You can also specify bands by clicking the Spectral Subset button.

SU
BS

ET
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6. �Accept all defaults and click OK.

7. �Highlight ROI #1 on the  
Spatial Subset via ROI  
Parameters dialog. 

8. �Enter an Output Filename  
by clicking Choose.

9. �Navigate to desired output  
directory and name the file 
something like “subset.dat”  
as seen in the example.

10. �Click OK.

11. �The newly created subset will 
be added to your View once 
processing is complete.  
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1. �Open the image you will orthorectify, along with the associated DEM 
if you have one. 

2. �From the Toolbox, select Geometric 
Correction > Orthorectification > RPC 
Orthorectification Workflow. The File 
Selection dialog appears. 

3. �Click Browse to select an image and 
DEM. If you do not have a DEM, use 
the default GMTED2010.jp2 file  
provided by ENVI. 

To perform orthorectification, the input image must have Rational Polynomial 
Coefficients (RPCs). Review the metadata to ensure this information is present. 
If you do not have elevation data, ENVI provides a default 30 arc-second (1 
km) DEM called GMTED2010.jp2 as part of the software installation. 

ORTHORECTIFY
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4. �Click Next to proceed to RPC Refinement. 

5. �Click the GCPs tab if  
you have Ground Control 
Points (GCPs) to add. GCPs 
improve accuracy. Click the 
Load GCPs button  to 
load the GCPs. The GCPs 
appear in the Ground Control 
Points field. Additionally, the 
Horizontal Accuracy value  
is adjusted from a value of  
0 (zero), indicating the  
orthorectification result  
will have better accuracy. 
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FY 6. �Take a moment to inspect the GCPs. Click on the GCPs in the Ground 

Control Points field and evaluate their properties in the GCP Properties 
field. Click the Help button  for more details. 

7. �Click the Advanced Tab.
 
8. �The Output Projection 

defaults to the coordinate 
system for the orthorectified 
image. To change it, click 
Browse and select a different 
coordinate system. 

9. �The Output Pixel Size defaults 
to the value derived from 
the pixel size of the input 
image. To change it, enter 
an Output Pixel Size in the 
same unit as the selected 
output projection. 
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10. �Select an Image Resampling technique. 

11. �Enter a Grid Spacing 
value. The default value 
is 10.

12. �Enable the Preview  
check box if you want to 
preview the orthorectified 
result before processing.

13. �Click the Statistics tab. 
Accept the default 
settings. Click the Help 
button  for details on 
GCP Statistics, Horizontal 
and Vertical Accuracies, 
and Error Overlay Threshold.
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Before and after ortho-examples. 
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FY 14. Click the Export Tab.

15. �Choose an Output File 
format.

16. �Click Browse and navigate 
to an output directory. 
Name the output file, 
then click Save.

17. �Enable the Preview check 
box to open a Portal View. 
Use the Portal View to 
visually inspect the results.

18. Click Finish.
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METHOD 1:  
NNDIFFUSE PAN SHARPENING

1. �Open your low resolution multi-spectral 
and high-resolution panchromatic  
images in an ENVI view. 

Panchromatic, or “pan” sharpening is an image merging process that allows 
users to create a new image by combining high-resolution panchromatic  
images with low-resolution, multispectral images to produce a color image 
for literal analysis. ENVI provides multiple methods. Only two have been 
selected for this guide to provide a basic understanding of the process. 
Proceed with Method 1 if your images do not require co-registration or 
atmospheric correction. Otherwise use Method 2. 

PANCHROMATIC SHARPEN
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2. �In the ENVI Toolbox, search for 
“NNDiffuse,” or select Image  
Sharpening > NNDiffuse Pan  
Sharpening. The NNDiffuse Pan 
Sharpening dialog appears. 

3. �Click the Browse button  
 next to the Input Low/High 

Resolution Raster fields, then select 
multispectral and panchromatic 
images, respectively.

4. �Use the marque zoom tool  to 
zoom into any area.

5. �Enable the Preview check box in the NNDiffuse Pan Sharpening window. 
A new view displays a preview of the pan-sharpened result. This allows 
you to visually inspect the before-and-after results before processing 
the data. 
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6. �If you are satisfied with the 
Preview results, select an 
Output Raster option. Choose 
File if you want to save the 
output. Click the Browse button 

 and navigate to an output 
directory. Name the output 
file, then click Save. Choose 
Virtual Raster if you want a 
memory-only output. 

7. �Enable the Display result 
check box if you want to  
display the result after  
processing.

8. Click OK.
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Before and after NNDiffuse pan sharpen examples:
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METHOD 2 : SPEAR PAN SHARPENING

1. �Open the high-resolution panchromatic and low-resolution  
multispectral images in ENVI. 

2. �In the ENVI Toolbox,  
select SPEAR > SPEAR  
Pan Sharpening. The Pan  
Sharpening workflow 
appears. 

3. �Click the Select High Res  
File button. Select a  
panchromatic image  
and click OK.

In this workflow, images will be co-registered and atmospherically 
corrected before proceeding with pan sharpening. 
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4. �Click the Select Low Res File 
button. Select a multispectral 
image and click OK.

5. �The Low Res Band Matching 
Choice dialog appears. A best 
practice is to choose Band 3 
because spectral properties 
in the red band closely match 
those of panchromatic  
images, which facilitates 
co-registration. Click OK. 

6. �Click Select Output File, navigate 
to an output directory and 
name the file *_pansharp.dat. 
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7. �The File Selection 
panel of the workflow 
should resemble the 
this example.

8. �Click Next. In the 
following window, 
enable Select tie 
points automatically.

9. �Ensure that Use seed points is enabled, and click Auto-Generate Seed 
Points. This allows ENVI to estimate GCPs. Alternatively, you can choose 
your own by clicking Select Seed Points. 
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10. �The Method Selection panel should resemble the following example:
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11. �Click Next. A series of windows will open in addition to the Pan 
Sharpening workflow. Bring the Image to Image GCP List forward.

12. �Click Options > Order Points by Error. The seed points with the  
highest RMS Error are brought to the top of the list.

13. �Highlight seed points with an RMS Error higher than 3, and click 
Delete.

14. �Bring forward the Pan Sharpening workflow, and set the Maximum 
allowable RMS per GCP value to 1.0. Click Apply.

15. �Choose the desired Warp Parameters. For this exercise, set Method to 
“Polynomial” and Interpolation to “Cubic Convolution.” Click Next.
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N 10. �In the final panel of the workflow, select a Sharpening Method. For 
this exercise, select Gram-Schmidt and click Next. Once processing is 
complete, click Export the image to NITF. Or, select File > Save As in 
the main window of the three-window display group. Then save the 
result to an image file or postscript file.
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1. �Click the Open File button  in the ENVI toolbar, and open two images 
over the same geographic region on different dates. 

2. �In the ENVI Toolbox, select Change Detection > Image Change Workflow. 
The Image Change workflow appears. 

3. �Click Browse next to Time #1 File and select the oldest/first image. Click OK. 

The steps in this section will produce a 2-Color Multi View (2CMV) Change 
Detection result. The end product will be a standard red and blue image 
based on changes that have taken place between images captured on two 
separate dates. Remember the phrase “red has fled” and “blue is new.” 
This exercise assumes the images are already co-registered. If your images 
are not co-registered, you have the option to automatically co-register 
them during the workflow.  

CHANGE DETECTION
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4. �Click Browse next to Time #2 File and select the newer/second image. 
Click Next.

5. �The Image Registration 
panel appears. If  
your images require  
co-registration,  
toggle Register  
Images Automatically.  
Otherwise, toggle Skip 
Image Registration.

  C
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6. �For Skip Image Registration, you can accept the defaults for the Repro-
jection Method and Resampling technique or select different options 
from the drop-down lists.

  CH
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7. �For Register Images Automatically, ENVI applies the registration values and 
settings based on the input files. You can accept the default values and 
settings or change them to have more control over the process. Click the 
Help button  for details.
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8. �Click Next. The Change Method Choice panel appears. 

9. �Accept the default 
Image Difference 
and click Next. 

10. �Accept the default 
Difference of Input 
Band and Band 1 
under Select Input 
Band. Click Next. 
The Thresholding 
or Export panel 
appears. 

  CH
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11. �Accept the default Apply Thresholding and click Next. The Change  
Thresholding panel appears. This panel lets you enter a manual threshold 
or use an Auto-Thresholding technique. 

12. �Under Select Change 
of Interest, you can 
choose Increase and 
Decrease, Increase 
Only, or Decrease Only. 
Increase and Decrease 
will return both red 
and blue 2CMV 
results. Red indicates 
decrease and blue 
indicates increase (“red 
has fled, blue is new”). 

13. �Under Select Auto-Thresholding Method, accept the default selection  
of Otsu’s. For a comprehensive explanation of Otsu’s, Tsai’s, Kapur’s, and 
Kittler’s thresholding methods, refer to the ENVI documentation. Click 
Next. The Cleanup panel appears.

  C
H

AN
GE

 D
ET

EC
TI

O
N

  



45

14. �The Cleanup panel lets you refine the results. Accept the defaults and 
click Next, or toggle Preview and manually adjust the previewed result 
to your liking. After clicking Next, the Export panel appears. 

15. �The Export panel lets 
you save both image 
and vector outputs. 
Click Browse on both 
the Export Change 
Class Image and Export 
Change Class Vectors. 
Navigate to your output 
directory and name the 
output files appropriate-
ly. Click Open, then click 
Finish. 

16. �Use the transparency 
slider to visually inspect 
the results.
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Old image, new image, change detection examples:
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1. �Open an image in ENVI through the Data 
Manager or by dragging and dropping from 
Windows Explorer or ArcCatalog. 

2. �From the Toolbox, click Anomaly Detection > 
Anomaly Detection Workflow. The Anomaly 
Detection wizard will appear. Click Next. 

Anomaly detection is a process performed on imagery to highlight  
significant or unnatural spectral differences in pixels versus neighboring 
values. Anomaly detection is useful in determining things such as disturbed 
earth or spikes in energy levels versus surroundings, for example. This 
process is useful in narrowing down searches to determine if and where 
further investigation is warranted.  

ANOMALY DETECTION
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3. �Select the RXD-UTD algorithm under Anomaly Detection Method. For 
a detailed explanation of this and other algorithms for this workflow, 
refer to the ENVI documentation. 

4. �Accept Global under Mean 
Calculation Method to 
process the spectrum of 
the full dataset. Select 
Suppress Vegetation if 
your image contains a lot 
of vegetation. Click Next.
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5. �The default value for Anomaly Percentage Threshold is 0.05. Accept 
this value, or adjust it using trial-and-error. The higher the threshold, 
the more data will be perceived as defects. Experiment with the  
Preview check box. Click Next. The Export panel appears.

6. �In the Export panel, ENVI 
will automatically append 
the image and vector 
output files to the root 
name. ENVI will also save 
the output files in the 
same directory as the 
input file. You can accept 
these defaults or change 
them by clicking Browse. 
Click Finish.
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7. �The results will  
automatically open 
in ENVI for further 
investigation and/or 
exploitation. White 
pixels in an image 
indicate anomalies. 
Red in a vector file 
indicates an anomaly.
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Input image, anomaly image overlayed with anomaly vector examples: 
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1. ���Open a multispectral image in 
ENVI for classification. 

2. �In the ENVI Toolbox, click  
Classification > Classification 
Workflow. The File Selection 
panel appears. 

3. �The multispectral file that you 
opened should be listed under 
Raster File. Click Next. The  
Classification Type panel appears.

ENVI provides a Classification Workflow that allows users to create a 
Landcover / Terrain Categorization (TERCAT) product. This process can 
be carried out by the software in an “Unsupervised” manner or by 
user-assigned spectra in a “Supervised’’ manner. The following exercise 
will conduct a Supervised classification. 

TERRAIN CATEGORIZATION 
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4. �Select Training Data to indicate that this is a ‘Supervised’ classification. 
Click Next. The Supervised Classification panel appears.

5. �Click the Add Class 
button  to add Training 
Data classification(s). 
Assign Class Names per 
region to the right under 
the Properties tab. Delete 
training data if necessary 
by highlighting items and 
clicking .
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been created, highlight a single 
class at a time. Then select 
spectral samples for that class by 
drawing polygons in the image 
around the features of interest. 
Use the ROI drawing tool in  
tandem with the navigation tools 
to zoom and pan around.

7. �The mouse wheel is useful in 
allowing you to zoom in and 
out based on the cursor position 
while in annotation mode.

8. �Select 8 to 10 varying spectral 
samples for each class by draw-
ing a polygon or rectangle. Then 
right-click and select Accept or 
Delete.
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9. �Once you are satisfied with spectral selection, toggle the Preview check 
box to launch a Portal View so you can inspect the results so far. Drag 
the Portal View around the View to inspect.  
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N 10. �If you are not satisfied with the previewed result, you can click the  
icon in the ENVI toolbar and select specific ROIs to remove. Press the 
Delete key to remove them if needed. Or, draw more polygons around 
representative features. 

11. �Click Next. The Cleanup 
panel appears. 

12. �The Cleanup panel 
allows you to optionally 
use smoothing  
algorithms to generalize 
the classification results. 
Adjust or accept the 
defaults and click  
Next. The Export  
panel appears.
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13. �ENVI will automatically 
append the image 
and vector output 
files to the root name. 
ENVI will also save 
the output files in the 
same directory as the 
input files. You can 
accept these defaults 
or change them by 
clicking Browse.  
Click Finish.
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1. �Generate a GEOTIFF with specialized vector 
overlays, drawings, pictures and/or text 
annotations. You can do this using the  
Annotations menu or in ArcMap as long  
as the GEOTIFF is accompanied by a  
corresponding World File. 

2. �In ENVI, open the newly created GEOTIFF 
by selecting File > Open and navigating to 
the location on disk. 

ENVI enables creation of the following RPF/CADRG resolutions:  
(1: 5,000,000 GNC (754m), 1: 2,000,000 JNC (300m), 1: 1,000,000 
ONC (150m), 1:500,000 TPC (75m), 1: 250,000 JOG (37.5m), 1: 
100,000 TLM (15m) and 1: 50,000 TLM (7.5m). Quality will depend 
on the scale and dots per inch (DPI) of the input, so take this into 
account during data preparation.

EXPORT TO RPF
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3. �Right-click on the file in the Layer Manager and select Zoom to Layer Full 
Resolution. Visually inspect the GEOTIFF. Next, right-click on the file in the 
Layer Manager and select Zoom to Layer Extent. If you are not satisfied 
with the visual inspection, make necessary adjustments such as DPI,  
overlays, etc., then export again before proceeding. 
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4. �In ENVI, click File > Save 
As > CADRG once you are 
satisfied with the newly 
created GEOTIFF. 

5. �Highlight the GEOTIFF 
under Select Input File. 

6. �Click OK. The RPF (CADRG) 
Output Parameters dialog 
appears. 

The GeoTIFF in this example was created in ArcMap at Scale 1: 25,000. 
It was exported from the Data view as a TIFF file with the Write World 
File option enabled under the General tab, and the Write GeoTiFF Tags 
option enabled under the Format tab. A DPI of 200 was used. 
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PF 7. Select an Output Directory. 

8. �Set the desired Resolution from the 
drop-down menu. In this example, 
1: 50,000 TLM Resolution was 
chosen. 

9. �Optional: Complete  
Classification, Country Code,  
and Release metadata. 

10. �Choose IMG2RPF as the  
Producer Code.

11. �Click OK. 

12. �Once processing is complete, navigate to the output directory  
and ensure you have the RPF data and the A.TOC file. 
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13. �Your Output directory’s contents should look similar to the  
example on page 64. 

14. � Visually inspect the newly 
created RPF data using 
Falconview. If dissatisfied, 
make refinements and 
repeat the preceding steps. 
Once satisfied, burn the 
entire RPF folder—including 
the A.TOC file—to disk to be 
loaded onto military aircraft 
and/or ground vehicles that 
rely on RPF data.  
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Start the ENVI Modeler using one of these options:

 • �Select Display > ENVI Modeler 
from the ENVI menu bar.

 • �In the ENVI Toolbox, expand 
the Task Processing folder and 
double-click ENVI Modeler.

 • �Drag and drop a .model file 
from Windows Explorer to 
the ENVI application.

This figure shows the main 
components of the ENVI  
Modeler user interface.

ENVI MODELER
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Elements of a Model

A model consists of two primary elements: nodes and connectors. A node 
is a basic building block such as an input file, task, or other operation. A 
connector is a grey line that connects nodes to one another via their input 
and output parameters. The following figure shows an example model with 
nodes and connectors:
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1. �Click the Open button  in the ENVI menu bar. Navigate to 
the examples folder in your ENVI installation path, and select 
the file “Modeler_Tutorial.model.” The default installation 
path is as follows, where xx is the ENVI version number:

 	 •  �Windows: C:\Program Files\Harris\ENVIxx\examples\

 	 • � Linux: /usr/local/harris/envixx/examples/

 	 •  �Macintosh: /Applications/harris/envixx/examples/

The sample model  
opens in an ENVI  
Modeler window: 
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ER 2. �Click the Run button  in the ENVI Modeler window to run the 
model.

3. �The model stops at the Input Parameters node so that you can select 
an image. In the Input Parameters dialog, click the Browse button .

4. In the Data Selection dialog, click the Open File button .

5. �Select a multispectral file; for example, “qb_boulder_msi.” This file is 
located in the data folder of the ENVI installation path. Click OK.

6. �Click OK in the Input Parameters dialog. The model runs and displays 
a smoothed classification image derived from the input multispectral 
image. The classification image is also added to the Data Manager 
and the view.
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Generate and Run Code From Models

IDL Programs and ENVI Toolbox Extensions

To generate IDL code for  
a model, select Code >  
Generate IDL Program 
from the ENVI Modeler 
menu bar. You must have 
an ENVI+IDL license to use 
this feature. The IDL code is 
displayed in a new Program 
window; for example:

From here, you can do the following:

 • To save the program to an IDL program file (.pro), click the Save button .

 • �To run the program, click the Run button . 

 • �To create an extension, click the Create Extension button . 
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You can generate Python code for a model if you want to use Python to 
call the ENVI Task Engine. To run the Python code that is generated, you 
must have the following installed:

       •  �Python 

       •  �pip 

       •  �One of the following: ENVI Py Engine, ENVI Py for ArGIS® Pro,  
or ENVIPy for ArcMap.

 
Select Code > 
Generate Python 
Program from 
the ENVI Modeler 
menu bar. The 
Python code is 
displayed in a new 
Program window; 
for example:
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From here, you can do the following:

       •  �To save the program to a Python program file (.py), click the Save 
button    .

       •  �To run the program, click the Run button .

       •  �To configure the output directory of the Python program, click the  
Configure Task Engine button    . Enter an Output Directory and 
click OK. All of the files generated by the model will be written to 
that directory.

When running a Python Program, the results will not be displayed or added 
to the Data Manager in ENVI. All the output rasters or vectors that are 
connected to an Output Parameters node will be preserved in the output 
folder. Other immediate files that are created will be immediately deleted 
upon running the program.
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You can save a model to a task file (.task) on disk so that you share the 
task with others or use it in the ENVI API, similar to a custom task. Follow 
these steps to save a model as a task file:

1. �Decide what inputs and outputs your metatask needs to expose. See  
Define Metatask Inputs and Outputs in the Create Models topic for details.

2. �Select Code > Generate Metatask from the ENVI Modeler menu bar. 
The task code is displayed in a new Metatask dialog.

3. �Choose a save option:

    • �Click the Save button  in the Metatask dialog. Select an output  
filename and directory for the .task file. See “Deploy Custom Task Files” 
in the ENVI documentation for recommendations on where to save 
.task files on your system.

    • �Click the Publish Task button in the Metatask dialog. In the Publish Task 
dialog, enter a Name, Display Name, Description, Revision, and Tags for 
the task. 
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    • �The default location for saving the task is shown. If you want to 
change this, select another option from the dropdown list.

    • �If you want to publish 
the task to ArcMap or 
ArcGIS Pro, check the 
appropriate box; this will 
make the task available 
to use directly from the 
ArcMap and/or ArcGIS 
Pro system toolbox the 
next time the product is 
started. Click OK. 
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